Install a FreeBSD 9 system with zfs root using the new installer: Start the install, drop to shell when it asks about disks, run these commands: # this first command assumes there has never been anything on the disk, # you may need to "gpart delete" some things first # also assumes there's nothing on the disk you want, buyer beware, etc. # don't blame me if you lose your data gpart create -s gpt ada0 gpart add -s 64K -t freebsd-boot ada0 # adjust swap size to taste gpart add -s 4G -t freebsd-swap -l swap0 ada0 gpart add -t freebsd-zfs -l disk0 ada0 gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1 ada0 mdconfig -a -t swap -s 16M newfs /dev/md2 mount /dev/md2 /boot/zfs sysctl kern.geom.debugflags=0x10 zpool create zroot ada0p3 zfs set mountpoint=/mnt zroot zfs mount zroot exit Finish install, select "Live CD" when installation is complete. login as root, no password cp /boot/zfs/zpool.cache /mnt/boot/zfs echo 'zfs_load="YES"' > /mnt/boot/loader.conf echo 'vfs.root.mountfrom="zfs:zroot"' >> /mnt/boot/loader.conf echo 'zfs_enable="YES"' >> /mnt/etc/rc.conf cat << EOF > /mnt/etc/fstab /dev/gpt/swap0 none swap sw 0 0 EOF zfs unmount -a zfs set mountpoint=legacy zroot zpool set bootfs=zroot zroot reboot # NOTE: # there may be better ways, see: # https://wiki.freebsd.org/RootOnZFS # http://www.aisecure.net/2012/01/16/rootzfs/ # http://forums.freebsd.org/showthread.php?t=31662