Background info: On the FreeBSD.org cluster we normally do in-place binary upgrades between the same major version. Today, something came up and we needed a fast update from 9.x to 10.x. What I did below isn't really supposed to work - I installed a 10.x userland under a running 9.x kernel, but hey, I got away with it. This machine is a jail host. We do the exact same procedure inside the jails, but for simplicity I've just left the smaller run for the host itself. We use etcupdate(8) rather than mergemaster. It's generally fully automatic and does 3-way merges to preserve local changes. It doesn't invite disaster like mergemaster does. The total phase 1 run time is about 90 seconds. The only interaction is during the post-upgrade pkg updates and it took about 60 seconds. The machine was serving part of www.freebsd.org while this happened. root@jet.ysv:/root # uname -a FreeBSD jet.ysv.freebsd.org 9.3-STABLE FreeBSD 9.3-STABLE #0: Mon Sep 8 10:02:58 UTC 2014 peter@build-9.freebsd.org:/usr/obj/usr/src/sys/CLUSTER9 amd64 (Cheat, specify a different fetch URL instead of the later version of 9.x) root@jet.ysv:/root # /etc/clusteradm/binaryupgrade.sh -u http://admin-http/install/amd64_10 Mirroring install files from http://admin-http/install/amd64_10 /scratch/_upgrade/base.txz 100% of 95 MB 102 MBps 00m01s /scratch/_upgrade/src.txz 100% of 322 MB 99 MBps 00m03s /scratch/_upgrade/obj.txz 100% of 277 MB 103 MBps 00m03s /scratch/_upgrade/oldfiles.txt 100% of 260 kB 65 MBps 00m00s /scratch/_upgrade/svnrev.txt 100% of 7 B 93 kBps 00m00s /scratch/_upgrade/manifest.txt 100% of 277 B 391 kBps 00m00s Checking manifest signature: ok Upgrade for jet.ysv.freebsd.org to files in /scratch/_upgrade - rev 271252 Taking a zfs snapshot of zjet@pre-upgrade Extracting /scratch/_upgrade/base.txz Preparing stage directory for upgrading and 3-way merging Backing up /boot/kernel to /boot/kernel.old Upgrading! ****** Point of no return! ****** etcupdate pass 1: extract build files to /var/db/etcupdate/current Purging etcupdate managed files from incoming root Moving libs to compat.. Upgrading system files.. Cleaning compat libs.. Extracting /scratch/_upgrade/src.txz in the background Extracting /scratch/_upgrade/obj.txz in the background doing a delete-old run: -r--r--r-- 1 root wheel 683 Jul 26 19:00 etc/mtree/BIND.chroot.dist lrwxr-xr-x 1 root wheel 23 Jan 3 2012 etc/namedb -> ../var/named/etc/namedb -rw-r--r-- 1 root wheel 471 Jul 26 19:00 etc/pam.d/kde -rwxr-xr-x 1 root wheel 1173 Jul 26 19:00 etc/periodic/daily/220.backup-pkgdb -rwxr-xr-x 1 root wheel 715 Jul 26 19:00 etc/periodic/daily/405.status-ata-raid -rwxr-xr-x 1 root wheel 1373 Jul 26 19:00 etc/periodic/daily/470.status-named -r-xr-xr-x 2 root wheel 5355376 Sep 8 10:04 rescue/atacontrol -r-xr-xr-x 2 root wheel 5355376 Sep 8 10:04 rescue/mount_ntfs -r-xr-xr-x 1 root wheel 16936 Sep 8 10:04 sbin/atacontrol -r-xr-xr-x 1 root wheel 12360 Sep 8 10:04 sbin/mount_ntfs -r-xr-xr-x 1 root wheel 37032 Sep 8 10:04 usr/bin/c++filt -r-xr-xr-x 1 root wheel 576760 Sep 8 10:04 usr/bin/cvs -r-xr-xr-x 1 root wheel 14034 Sep 8 10:04 usr/bin/cvsbug -r-xr-xr-x 1 root wheel 1902424 Sep 8 10:05 usr/bin/dig -r-xr-xr-x 1 root wheel 203448 Sep 8 10:04 usr/bin/g++ -r-xr-xr-x 1 root wheel 203448 Sep 8 10:04 usr/bin/g++ -r-xr-xr-x 1 root wheel 458784 Sep 8 10:04 usr/bin/gcc -r-xr-xr-x 1 root wheel 25912 Sep 8 10:04 usr/bin/gcov -r-xr-xr-x 1 root wheel 203448 Sep 8 10:04 usr/bin/gcpp -r-xr-xr-x 1 root wheel 931208 Sep 8 10:04 usr/bin/gnu-ar -r-xr-xr-x 1 root wheel 931208 Sep 8 10:04 usr/bin/gnu-ranlib -r-xr-xr-x 1 root wheel 13120 Sep 8 10:05 usr/bin/ncplist -r-xr-xr-x 2 root wheel 9024 Sep 8 10:05 usr/bin/ncplogin -r-xr-xr-x 2 root wheel 9024 Sep 8 10:05 usr/bin/ncplogout -r-xr-xr-x 1 root wheel 1891480 Sep 8 10:05 usr/bin/nslookup -r-xr-xr-x 1 root wheel 1855736 Sep 8 10:05 usr/bin/nsupdate -r-xr-xr-x 1 root wheel 11648 Sep 8 10:05 usr/bin/otp-sha -r-xr-xr-x 1 root wheel 6472 Sep 8 10:05 usr/bin/wtmpcvt -r-xr-xr-x 1 root wheel 2322 Sep 8 10:05 usr/bin/yyfix -r-xr-xr-x 1 root wheel 6383368 Sep 8 10:04 usr/libexec/cc1 -r-xr-xr-x 1 root wheel 6934864 Sep 8 10:04 usr/libexec/cc1plus -r-xr-xr-x 1 root wheel 6934864 Sep 8 10:04 usr/libexec/cc1plus -r-xr-xr-x 1 root wheel 6016 Sep 8 10:05 usr/sbin/arpaname -r-xr-xr-x 1 root wheel 18168 Sep 8 10:05 usr/sbin/burncd -r-xr-xr-x 1 root wheel 567208 Sep 8 10:05 usr/sbin/ddns-confgen -r-xr-xr-x 1 root wheel 1765648 Sep 8 10:05 usr/sbin/dnssec-dsfromkey -r-xr-xr-x 1 root wheel 1769744 Sep 8 10:05 usr/sbin/dnssec-keyfromlabel -r-xr-xr-x 1 root wheel 1777936 Sep 8 10:05 usr/sbin/dnssec-keygen -r-xr-xr-x 1 root wheel 1761552 Sep 8 10:05 usr/sbin/dnssec-revoke -r-xr-xr-x 1 root wheel 1769744 Sep 8 10:05 usr/sbin/dnssec-settime -r-xr-xr-x 1 root wheel 1811016 Sep 8 10:05 usr/sbin/dnssec-signzone -r-xr-xr-x 1 root wheel 1769944 Sep 8 10:05 usr/sbin/dnssec-verify -r-xr-xr-x 1 root wheel 12752 Sep 8 10:05 usr/sbin/genrandom -r-xr-xr-x 1 root wheel 100368 Sep 8 10:05 usr/sbin/isc-hmac-fixup -r-xr-xr-x 2 root wheel 2396784 Sep 8 10:06 usr/sbin/lwresd -r-xr-xr-x 1 root wheel 16744 Sep 8 10:06 usr/sbin/mount_nwfs -r-xr-xr-x 1 root wheel 22616 Sep 8 10:06 usr/sbin/mount_portalfs -r-xr-xr-x 2 root wheel 2396784 Sep 8 10:06 usr/sbin/named -r-xr-xr-x 1 root wheel 1853416 Sep 8 10:06 usr/sbin/named-checkconf -r-xr-xr-x 2 root wheel 1753672 Sep 8 10:06 usr/sbin/named-checkzone -r-xr-xr-x 2 root wheel 1753672 Sep 8 10:06 usr/sbin/named-compilezone -r-xr-xr-x 1 root wheel 1736856 Sep 8 10:06 usr/sbin/named-journalprint -r-xr-xr-x 1 root wheel 153928 Sep 8 10:06 usr/sbin/nsec3hash -r-xr-xr-x 1 root wheel 357600 Sep 8 10:06 usr/sbin/rndc -r-xr-xr-x 1 root wheel 566984 Sep 8 10:06 usr/sbin/rndc-confgen -r-xr-xr-x 1 root wheel 789256 Sep 8 10:06 usr/sbin/sysinstall -rw-r--r-- 1 root wheel 234 Oct 23 2012 var/named/etc/namedb/master/empty.db -rw-r--r-- 1 root wheel 256 Oct 23 2012 var/named/etc/namedb/master/localhost-forward.db -rw-r--r-- 1 root wheel 324 Oct 23 2012 var/named/etc/namedb/master/localhost-reverse.db -rw-r--r-- 1 root wheel 3250 Jul 26 19:00 var/named/etc/namedb/named.root etcupdate pass 2: attempt auto-merge D /etc/rc.d/encswap D /etc/rc.d/named D /etc/rc.d/swap1 D /var/named/etc/namedb/named.conf D /var/named/etc/namedb/master U /COPYRIGHT U /boot/device.hints U /etc/amd.map U /etc/apmd.conf U /etc/bluetooth/hcsecd.conf U /etc/bluetooth/hosts U /etc/bluetooth/protocols U /etc/crontab U /etc/csh.cshrc U /etc/csh.login U /etc/csh.logout U /etc/ddb.conf U /etc/defaults/bluetooth.device.conf U /etc/defaults/devfs.rules U /etc/defaults/periodic.conf U /etc/defaults/rc.conf U /etc/devd.conf U /etc/devd/asus.conf U /etc/devd/uath.conf U /etc/devd/usb.conf U /etc/devfs.conf U /etc/dhclient.conf U /etc/disktab U /etc/fbtab U /etc/freebsd-update.conf U /etc/ftpusers U /etc/gettytab M /etc/group U /etc/gss/mech U /etc/gss/qop U /etc/hosts U /etc/hosts.allow U /etc/hosts.equiv U /etc/hosts.lpd U /etc/inetd.conf U /etc/libalias.conf U /etc/libmap.conf U /etc/libmap32.conf U /etc/locate.rc U /etc/login.access U /etc/login.conf U /etc/mac.conf U /etc/mail/Makefile U /etc/mail/README U /etc/mail/access.sample U /etc/mail/aliases U /etc/mail/freebsd.cf U /etc/mail/freebsd.mc U /etc/mail/freebsd.submit.cf U /etc/mail/freebsd.submit.mc U /etc/mail/mailertable.sample U /etc/mail/sendmail.cf U /etc/mail/submit.cf U /etc/mail/virtusertable.sample M /etc/master.passwd U /etc/mtree/BSD.include.dist U /etc/mtree/BSD.root.dist U /etc/mtree/BSD.sendmail.dist U /etc/mtree/BSD.usr.dist U /etc/mtree/BSD.var.dist U /etc/netconfig U /etc/netstart U /etc/network.subr U /etc/networks U /etc/newsyslog.conf U /etc/nscd.conf U /etc/nsmb.conf U /etc/nsswitch.conf U /etc/opieaccess U /etc/pam.d/README U /etc/pam.d/atrun U /etc/pam.d/cron U /etc/pam.d/ftp U /etc/pam.d/imap U /etc/pam.d/login U /etc/pam.d/other U /etc/pam.d/passwd U /etc/pam.d/pop3 U /etc/pam.d/rsh U /etc/pam.d/sshd U /etc/pam.d/su U /etc/pam.d/system U /etc/pam.d/telnetd U /etc/pam.d/xdm U /etc/pccard_ether U /etc/periodic/daily/100.clean-disks U /etc/periodic/daily/110.clean-tmps U /etc/periodic/daily/120.clean-preserve U /etc/periodic/daily/130.clean-msgs U /etc/periodic/daily/140.clean-rwho U /etc/periodic/daily/150.clean-hoststat U /etc/periodic/daily/200.backup-passwd U /etc/periodic/daily/210.backup-aliases U /etc/periodic/daily/300.calendar U /etc/periodic/daily/310.accounting U /etc/periodic/daily/330.news U /etc/periodic/daily/400.status-disks U /etc/periodic/daily/401.status-graid U /etc/periodic/daily/404.status-zfs U /etc/periodic/daily/406.status-gmirror U /etc/periodic/daily/407.status-graid3 U /etc/periodic/daily/408.status-gstripe U /etc/periodic/daily/409.status-gconcat U /etc/periodic/daily/420.status-network U /etc/periodic/daily/430.status-rwho U /etc/periodic/daily/440.status-mailq U /etc/periodic/daily/450.status-security U /etc/periodic/daily/460.status-mail-rejects U /etc/periodic/daily/480.status-ntpd U /etc/periodic/daily/500.queuerun U /etc/periodic/daily/800.scrub-zfs U /etc/periodic/daily/999.local U /etc/periodic/monthly/200.accounting U /etc/periodic/monthly/999.local U /etc/periodic/security/100.chksetuid U /etc/periodic/security/110.neggrpperm U /etc/periodic/security/200.chkmounts U /etc/periodic/security/300.chkuid0 U /etc/periodic/security/400.passwdless U /etc/periodic/security/410.logincheck U /etc/periodic/security/500.ipfwdenied U /etc/periodic/security/510.ipfdenied U /etc/periodic/security/520.pfdenied U /etc/periodic/security/550.ipfwlimit U /etc/periodic/security/610.ipf6denied U /etc/periodic/security/700.kernelmsg U /etc/periodic/security/800.loginfail U /etc/periodic/security/900.tcpwrap U /etc/periodic/security/security.functions U /etc/periodic/weekly/310.locate U /etc/periodic/weekly/320.whatis U /etc/periodic/weekly/330.catman U /etc/periodic/weekly/340.noid U /etc/periodic/weekly/999.local U /etc/pf.os U /etc/phones U /etc/pkg/FreeBSD.conf U /etc/portsnap.conf U /etc/ppp/ppp.conf U /etc/printcap U /etc/profile U /etc/protocols U /etc/rc U /etc/rc.bsdextended U /etc/rc.d/DAEMON U /etc/rc.d/FILESYSTEMS U /etc/rc.d/LOGIN U /etc/rc.d/NETWORKING U /etc/rc.d/SERVERS U /etc/rc.d/abi U /etc/rc.d/accounting U /etc/rc.d/addswap U /etc/rc.d/adjkerntz U /etc/rc.d/amd U /etc/rc.d/apm U /etc/rc.d/apmd U /etc/rc.d/archdep U /etc/rc.d/atm1 U /etc/rc.d/atm2 U /etc/rc.d/atm3 U /etc/rc.d/auditd U /etc/rc.d/auditdistd U /etc/rc.d/bgfsck U /etc/rc.d/bluetooth U /etc/rc.d/bootparams U /etc/rc.d/bridge U /etc/rc.d/bsnmpd U /etc/rc.d/bthidd U /etc/rc.d/ccd U /etc/rc.d/cleanvar U /etc/rc.d/cleartmp U /etc/rc.d/cron U /etc/rc.d/ddb U /etc/rc.d/defaultroute U /etc/rc.d/devd U /etc/rc.d/devfs U /etc/rc.d/dhclient U /etc/rc.d/dmesg U /etc/rc.d/dumpon U /etc/rc.d/faith U /etc/rc.d/fsck U /etc/rc.d/ftp-proxy U /etc/rc.d/ftpd U /etc/rc.d/gbde U /etc/rc.d/geli U /etc/rc.d/geli2 U /etc/rc.d/gptboot U /etc/rc.d/gssd U /etc/rc.d/hastd U /etc/rc.d/hcsecd U /etc/rc.d/hostapd U /etc/rc.d/hostid U /etc/rc.d/hostid_save U /etc/rc.d/hostname U /etc/rc.d/inetd U /etc/rc.d/initrandom U /etc/rc.d/ip6addrctl U /etc/rc.d/ipfilter U /etc/rc.d/ipfs U /etc/rc.d/ipfw U /etc/rc.d/ipmon U /etc/rc.d/ipnat U /etc/rc.d/ipsec U /etc/rc.d/ipxrouted U /etc/rc.d/jail U /etc/rc.d/kadmind U /etc/rc.d/kerberos U /etc/rc.d/keyserv U /etc/rc.d/kld U /etc/rc.d/kldxref U /etc/rc.d/kpasswdd U /etc/rc.d/ldconfig U /etc/rc.d/local U /etc/rc.d/localpkg U /etc/rc.d/lockd U /etc/rc.d/lpd U /etc/rc.d/mdconfig U /etc/rc.d/mdconfig2 U /etc/rc.d/mixer U /etc/rc.d/motd U /etc/rc.d/mountcritlocal U /etc/rc.d/mountcritremote U /etc/rc.d/mountd U /etc/rc.d/mountlate U /etc/rc.d/moused U /etc/rc.d/mroute6d U /etc/rc.d/mrouted U /etc/rc.d/msgs U /etc/rc.d/natd U /etc/rc.d/netif U /etc/rc.d/netoptions U /etc/rc.d/netwait U /etc/rc.d/newsyslog U /etc/rc.d/nfscbd U /etc/rc.d/nfsclient U /etc/rc.d/nfsd U /etc/rc.d/nfsuserd U /etc/rc.d/nisdomain U /etc/rc.d/nscd U /etc/rc.d/nsswitch U /etc/rc.d/ntpd U /etc/rc.d/ntpdate U /etc/rc.d/othermta U /etc/rc.d/pf U /etc/rc.d/pflog U /etc/rc.d/pfsync U /etc/rc.d/power_profile U /etc/rc.d/powerd U /etc/rc.d/ppp U /etc/rc.d/pppoed U /etc/rc.d/pwcheck U /etc/rc.d/quota U /etc/rc.d/random U /etc/rc.d/rarpd U /etc/rc.d/rctl U /etc/rc.d/resolv U /etc/rc.d/rfcomm_pppd_server U /etc/rc.d/root U /etc/rc.d/route6d U /etc/rc.d/routed U /etc/rc.d/routing U /etc/rc.d/rpcbind U /etc/rc.d/rtadvd U /etc/rc.d/rtsold U /etc/rc.d/rwho U /etc/rc.d/savecore U /etc/rc.d/sdpd U /etc/rc.d/securelevel U /etc/rc.d/sendmail U /etc/rc.d/serial U /etc/rc.d/sppp U /etc/rc.d/sshd U /etc/rc.d/statd U /etc/rc.d/static_arp U /etc/rc.d/static_ndp U /etc/rc.d/stf U /etc/rc.d/syscons U /etc/rc.d/sysctl U /etc/rc.d/syslogd U /etc/rc.d/timed U /etc/rc.d/tmp U /etc/rc.d/ubthidhci U /etc/rc.d/ugidfw U /etc/rc.d/var U /etc/rc.d/virecover U /etc/rc.d/watchdogd U /etc/rc.d/wpa_supplicant U /etc/rc.d/ypbind U /etc/rc.d/yppasswdd U /etc/rc.d/ypserv U /etc/rc.d/ypset U /etc/rc.d/ypupdated U /etc/rc.d/ypxfrd U /etc/rc.d/zfs U /etc/rc.d/zvol U /etc/rc.firewall U /etc/rc.initdiskless U /etc/rc.resume U /etc/rc.sendmail U /etc/rc.shutdown U /etc/rc.subr U /etc/rc.suspend U /etc/regdomain.xml U /etc/remote U /etc/rpc U /etc/security/audit_class M /etc/security/audit_control U /etc/security/audit_event U /etc/security/audit_user U /etc/security/audit_warn U /etc/services U /etc/shells U /etc/snmpd.config U /etc/ssh/ssh_config U /etc/ssl/openssl.cnf M /etc/sysctl.conf U /etc/syslog.conf U /etc/termcap.small M /etc/ttys M /root/.cshrc U /root/.login U /root/.profile A /etc/auto_master A /etc/autofs/include_ldap A /etc/autofs/special_hosts A /etc/autofs/special_null A /etc/periodic/monthly/450.status-security A /etc/periodic/weekly/450.status-security A /etc/rc.d/automount A /etc/rc.d/automountd A /etc/rc.d/autounmountd A /etc/rc.d/ctld A /etc/rc.d/iscsictl A /etc/rc.d/iscsid A /etc/rc.d/kfd A /etc/rc.d/local_unbound A /etc/rc.d/postrandom A /etc/rc.d/swap A /etc/rc.d/swaplate A /etc/rc.d/utx A /etc/unbound etcupdate status = clean! Updating bootblocks.. bootcode written to da3 bootcode written to da2 bootcode written to da1 bootcode written to da0 (Waiting for background extract tasks..) (kicking clusteradm update.sh) Running pkg upgrade; you can skip if desired. pkg-static: Warning: Major version upgrade detected. Running "pkg-static install -f pkg" recommended pkg-static: wrong architecture: freebsd:9:x86:64 instead of freebsd:10:x86:64 pkg-static: repository default contains packages with wrong ABI: freebsd:9:x86:64 pkg-static: Unable to update repository default pkg-static: Warning: Major version upgrade detected. Running "pkg-static install -f pkg" recommended Updating default repository catalogue... default repository is up-to-date. All repositories are up-to-date. Checking for upgrades (2 candidates): 100% Checking integrity... done (0 conflicting) Your packages are up to date. Ready for reboot! root@jet.ysv:/root # etcupdate resolve root@jet.ysv:/root # reboot [later, after reboot] root@jet.ysv:/home/peter # /etc/clusteradm/postupgrade.sh Cleaning pre-upgrade snapshot Deleting /scratch/_upgrade Purging zjet/usr/src.previous Purging zjet/usr/obj.previous Boot code was updated, doing a zpool upgrade: This system supports ZFS pool feature flags. Enabled the following features on 'zjet': embedded_data Running pkg upgrade; you can skip if desired. Updating default repository catalogue... pkg: Repository default has a wrong packagesite, need to re-create database Fetching meta.txz: 100% 1 KB 1.3k/s 00:01 Fetching digests.txz: 100% 75 KB 76.6k/s 00:01 Fetching packagesite.txz: 100% 222 KB 226.9k/s 00:01 Processing new repository entries: 100% default repository update completed. 847 packages processed: 0 updated, 0 removed and 847 added. New version of pkg detected; it needs to be installed first. The following 1 packages will be affected (of 0 checked): Installed packages to be REINSTALLED: pkg-1.3.7 (ABI changed) The process will require 2 MB more space. 2 MB to be downloaded. Proceed with this action? [y/N]: y Fetching pkg-1.3.7.txz: 100% 2 MB 2.4M/s 00:01 Checking integrity... done (0 conflicting) [1/1] Reinstalling pkg-1.3.7: 100% Updating default repository catalogue... default repository is up-to-date. All repositories are up-to-date. Checking for upgrades (12 candidates): 100% The following 12 packages will be affected (of 0 checked): Installed packages to be UPGRADED: subversion: 1.8.10_1 -> 1.8.10_2 rsync: 3.1.1_2 -> 3.1.1_3 Installed packages to be REINSTALLED: tmux-1.9.a_2 (ABI changed) serf-1.3.7_1 (ABI changed) apr-1.5.1.1.5.3_4 (ABI changed) expat-2.1.0_1 (ABI changed) libiconv-1.14_4 (ABI changed) gettext-0.18.3.1_1 (ABI changed) indexinfo-0.2 (ABI changed) sqlite3-3.8.6 (ABI changed) ipmitool-1.8.14_1 (ABI changed) dmidecode-2.12 (ABI changed) The process will require 569 KB more space. 7 MB to be downloaded. Proceed with this action? [y/N]: y Fetching tmux-1.9.a_2.txz: 100% 250 KB 256.2k/s 00:01 Fetching subversion-1.8.10_2.txz: 100% 2 MB 2.5M/s 00:01 Fetching serf-1.3.7_1.txz: 100% 77 KB 78.9k/s 00:01 Fetching apr-1.5.1.1.5.3_4.txz: 100% 393 KB 402.9k/s 00:01 Fetching expat-2.1.0_1.txz: 100% 99 KB 101.8k/s 00:01 Fetching libiconv-1.14_4.txz: 100% 594 KB 608.0k/s 00:01 Fetching gettext-0.18.3.1_1.txz: 100% 2 MB 2.2M/s 00:01 Fetching indexinfo-0.2.txz: 100% 6 KB 6.6k/s 00:01 Fetching sqlite3-3.8.6.txz: 100% 718 KB 734.9k/s 00:01 Fetching rsync-3.1.1_3.txz: 100% 288 KB 294.6k/s 00:01 Fetching ipmitool-1.8.14_1.txz: 100% 326 KB 333.8k/s 00:01 Fetching dmidecode-2.12.txz: 100% 61 KB 62.8k/s 00:01 Checking integrity... done (0 conflicting) [1/12] Reinstalling expat-2.1.0_1: 100% [2/12] Reinstalling libiconv-1.14_4: 100% [3/12] Reinstalling apr-1.5.1.1.5.3_4: 100% [4/12] Reinstalling indexinfo-0.2: 100% [5/12] Reinstalling serf-1.3.7_1: 100% [6/12] Reinstalling gettext-0.18.3.1_1: 100% [7/12] Reinstalling sqlite3-3.8.6: 100% [8/12] Reinstalling tmux-1.9.a_2: 100% [9/12] Upgrading subversion from 1.8.10_1 to 1.8.10_2: 100% [10/12] Upgrading rsync from 3.1.1_2 to 3.1.1_3: 100% [11/12] Reinstalling ipmitool-1.8.14_1: 100% [12/12] Reinstalling dmidecode-2.12: 100% (kicking clusteradm update.sh) (and remove subversion while here, its in the base now) root@jet.ysv:/home/peter # pkg delete subversion Checking integrity... done (0 conflicting) Deinstallation has been requested for the following 1 packages (of 0 packages in the universe): Installed packages to be REMOVED: subversion-1.8.10_2 The operation will free 14 MB. Proceed with deinstalling packages? [y/N]: y [1/1] Deleting subversion-1.8.10_2: 100% root@jet.ysv:/home/peter # pkg autoremove Checking integrity... done (0 conflicting) Deinstallation has been requested for the following 7 packages: Installed packages to be REMOVED: apr-1.5.1.1.5.3_4 serf-1.3.7_1 expat-2.1.0_1 gettext-0.18.3.1_1 indexinfo-0.2 libiconv-1.14_4 sqlite3-3.8.6 The operation will free 18 MB. Proceed with deinstalling packages? [y/N]: y [1/7] Deleting serf-1.3.7_1: 100% [2/7] Deleting apr-1.5.1.1.5.3_4: 100% [3/7] Deleting gettext-0.18.3.1_1: 100% [4/7] Deleting expat-2.1.0_1: 100% [5/7] Deleting indexinfo-0.2: 100% [6/7] Deleting libiconv-1.14_4: 100% [7/7] Deleting sqlite3-3.8.6: 100% root@jet.ysv:/home/peter # pkg info dmidecode-2.12 Tool for dumping DMI (SMBIOS) contents in human-readable format ipmitool-1.8.14_1 CLI to manage IPMI systems pkg-1.3.7 Package manager rsync-3.1.1_3 Network file distribution/synchronization utility tmux-1.9.a_2 Terminal Multiplexer root@jet.ysv:/home/peter #