Building Bootable FreeBSD Images ******************************** Set up the build-environment ... 1. setenv MAKEOBJDIRPREFIX /blah 2. setenv TARGET i386 3. setenv TARGET_ARCH i386 Build everything (userland, and kernel) ... 4. make buildworld 5. make buildkernel KERNCONF=GENERIC Prepare a flash disk ... 6. fdisk -I da0 7. fdisk -B da0 8. bsdlabel -w da0s1 auto 9. bsdlabel -B da0s1 10. newfs /dev/da0s1a 11. mount /dev/da0s1a /mnt Install userland and kernel ... 12. make installworld DESTDIR=/mnt 13. make installkernel DESTDIR=/mnt KERNCONF=GENERIC INSTALL_NODEBUG=t Added the extra files needed for boot ... 14. make distrib-dirs DESTDIR=/mnt 15. make distribution DESTDIR=/mnt 16. echo /dev/da0s1a / ufs rw 1 1 > /mnt/etc/fstab 17. echo ifconfig_DEFAULT=DHCP > /mnt/etc/rc.conf 18. echo hostname=demo >> /mnt/etc/rc.conf ------------------------------------------------------------------------ This text has been copied from a blog post by Warner Losh, available at: http://bsdimp.blogspot.com/2007/10/building-bootable-freebsdi386-images.html